AMAPstudio

User Tools


The Capsis Manual

Introduction

Capsis (Computer-Aided Projection for Strategies In Silviculture) is a generic simulation platform to study growth and dynamics of forests and plantations. It was designed arround a software kernel providing common features and generic data structures and modules implementing the dynamics models for given species and regions.

At the beginning of a simulation, an initial stand must be provided by the chosen module, by reading an inventory file or by some virtual generation method. The resulting root step determines a project and can be the basis for various simulations, by alternating evolution phases with interventions to build silvicultural scenarios.

General view : Two projects in the project manager (interactive pilot)

The evolution process from a given step is delegated to the module. The latter contains an evolution loop which invokes the methods for growth, regeneration, mortality… (having regard to the modules) for each step to be created depending on a custom simulation step (free).

An intervention on a given step (thinning, pruning, fertilizing…) are delegated to an extension (which type is Intervener) which create a new step carrying the stand resulting from the intervention.

Models of different types (individual based, distance dependent or not, stand type, mixed types, continuous time…) can coexist in different Capsis modules describing different data structures. Each one can make use of a custom extensions set. Other extensions are called generic because they are compatible with several modules.

The Capsis platform is co-developed by computer scientists, dealing with the community and technical matters and research workers responsible for the development of their module.

Installation

Capsis is compatible with the Windows and Linux operating systems (tested). Due to its Java implementation language, highly portable, Capsis may be usable on other systems, but only Windows and Linux are officially supported.

To install Capsis, you must first install a Java Virtual Machine by Sun Microsystems.

Installation procedure is explained in the installation guide.

Frequently Asked Question

See the FAQ

How to get Help

If you want to know the main features of Capsis, read the tutorial . To get help on a given module or a specific Capsis feature, check the online help accessible from the Help > About Capsis dialog (select a module and click on the Information icon) or from one of the Help buttons in the application dialogs.

For more information on the Capsis project, check the Capsis web site . For general or technical information, ask by mail (see contact).

Finally, for scientific information about the modules under Capsis, send directly a mail to the author of the module by consulting the project page of the Capsis web site.

Project, module, session

Each forestry growth or dynamics model implemented in Capsis corresponds with a module in the platform (ex: mountain module, Spruce in the french Alps).

To use a given model, you must create a new project and link to it the matching module chosen in the list of the modules available in the platform. During the following initialization phase, you have to set the model parameters and to choose a beginning stand for the simulations in this project. At the end of this phase, you get a project (fig. 1) containing a root step, basis for the future simulations and carrying the beginning stand.

Fig. 1. New project

It is possible to work at the same time on several projects. All the opened projects are part of the working session . The projects can be saved separately or at the same time by saving the whole session for a faster future reopening. Projects can always be opened individually, even if they were saved together in the session. The File menu can be used to manage the whole session, while the project can be individually managed by the Project menu.

Evolution

From the root step (or then from whatever step), you can trigger an evolution phase (fig. 2) by action on the Step Popup Menu (right click on the chosen step).

Fig. 2. Evolution from a step by the Step Popup Menu

Set the evolution parameters (number of days, years, target date (…) depending on the model), then validate. The module evolution method is triggered and builds some new steps which are added to the scenario after the beginning step.

Intervention

On a chosen step, trigger an intervention by using the Step Popup Menu (fig. 3).

Fig. 3. Intervention on a chosen step

Once the intervention is correctly set and validated, a new step carrying its result is built and linked to the original step (ex: less trees if thinning).

Groups

Groups concern stands with individual trees inside (spatialized or not) or plots divided into square or polygonal cells.

Building a group always occurs relatively to the current step (the last one which was selected). The stand of this step is used as a basis for the operation. The Group Catalog (fig. 4) can be opened by the Step Menu or by the Group Icon in the main Capsis Toolbar (or sometimes from another tool preference dialog).

Fig. 4. The Group Icon opens the Group Catalog

A group can be created with the Group Manager (fig. 5), by combining filters into successive refinements. Filters are extension of the platform which can recognize their compatibility with the modules by making dynamic tests (ex: do the stand description of this module contain spatialized trees ?).

Fig. 5. From the Catalog, customize the group : H < 5m.

When a group is built (it then has a name), it is saved and will be reloaded each time Capsis is launched. Groups are usable in some tools (viewers, graphical outputs) to study sub populations (ex: trees greater than 35 m., cells at the north…).

Open and synchronize viewers and graphical outputs

To control the simulations, it is possible to open viewers and graphical outputs by action on the Selector .

  • Select a current step (left click) in the project manager,
  • Select a tool in the selector (double click),
  • The tool is opened and synchronized on the colored step.

Fig. 6. Opening a viewer on step 2010a

To move tools from one step to another in the same project, click on the source colored step, then click 2 times on the target step. To close a tool, use the close icon in its title bar. To close all the tools synchronized on a given step, ctrl-click the step.

Viewers

Access by the Selector (see previous paragraph) .

These tools can be synchronized with a project step and give a representation of the carried stand (fig. 7). This representation can be graphical (map, distribution…) or not (text, table).

Fig. 7. A viewer : the explorer shows the trees of the stand in a table

Generally (but not always), viewers propose to restrict to a given group which can be created on the fly with their configuration dialog.

To open a viewer, select a step in the project manager, then select a viewer in the Selector (left click).

Graphical outputs

Access by the Selector (see previous section) .

They are data extractors which can provide representation of the state of a stand at a given date, or a representation of the evolution of a property along time (fig. 8). The great difference with the viewers is that graphical outputs can generally draw data from several steps of several projects on the same representation (graphical or not) for comparisons.

Such extractors are provided for classical dendrometrical properties. Modelers can write their own data extractors for their special needs.

To open a graphical output, same way than for a viewer (see previous section).

Fig. 8. A data extractor showing evolution of the number of trees per hectare along time for two scenarios of the vtx project. A thinning action can be noted in 2005 for scenario a.

To add a new extractor in an opened graphic, select the step in the project manager, then ctrl-click in the graphic.

To remove an extractor from a graphic, use the graphic popup menu (right click on the graphic). Graphics are configurable from the same popup menu.

Export

Export is accessible from the Step Popup Menu if compatible export extensions are available (fig. 9).

Fig. 9. The export dialog can be opened on a step with the Step Popup Menu

The export extensions describe an export format for data under the reference Step into a file which name can be chosen.

Generic tools

The Tools menu in the main menu bar proposes general tools without compatibility notion (ex: editor, extension manager, memory control…).

ToolBox

These special tools can be accessed by the Step Popup Menu (if available). They propose analysis methods, connections with other simulaion software or heavy representation (ex: 3D viewers).

help/capsis.txt · Last modified: 2013/05/23 08:25 (external edit)