AMAPstudio

User Tools


Tutorial : Démarrer avec Capsis

Lancement de Capsis

Placez vous dans le répertoire capsis_install_directory/capsis4/ et lancez le script de démarrage de Capsis (par défaut, démarrage en français).

Windows
cd capsis_install_directory\capsis4
capsis

# Optionnel : démarrer Capsis en anglais
capsis -l en
Linux / Mac OS X
cd capsis_install_directory/capsis4
sh capsis.sh

# Optionnel : démarrer Capsis en anglais
sh capsis.sh -l en

Consultez les options de lancement avec l'option -h (ex: capsis -h).

Modèles disponibles

Capsis héberge des modèles pour simuler la croissance / dynamique de forêts ou de plantations.

Pour connaître la liste des modèles installés, choisissez Aide > A propos de Capsis. Laboite de dialogue montre la liste des modèles disponibles.

Création d'un projet

Toutes les simulations sont lancées dans des projets. Chaque projet est associé à un modèle Capsis spécifique, choisi au moment de son initialisation. Les projets mémorisent les différentes étapes de l'historique de la simulation. Chaque étape a une date et mémorise l'état du peuplement à cette date, calculé par le modèle associé.

Tout projet comporte toujours une étape racine, supportant le peuplement de départ des simulations, soit chargé depuis un fichier, soit généré virtuellement.

  1. Projet > Nouveau
  2. Choisissez un nom pour le projet
  3. Selectionnez le modèle associé : eg Mountain
  4. Appuyez sur le bouton Initialiser
  5. Spécifiez le peuplement initial : Inventaire > Peuplement virtuel
  6. Contrôlez les autres options : Terrain > Cellules > Largeur de cellule (m) : 10
  7. Validez

Gestion des projets

Une fois le projet initialisé (paramètres du modèle positionnés et peuplement initial chargé), il apparaît dans le Gestionnaire de Projets. Un entête montre ses principales propriétés (nom du projet, nom du modèle, surface…) et le peuplement initial est associé à l'étape racine avec une date.

Le Gestionnaire de Projets fournit un menu contextuel d'étape (le menu Etape) qui propose des options de gestion pour l'étape en question.

Quand vous cliquez sur une étape (bouton de gauche), elle devient l'Etape Courante (avec un aspect enfoncé) et le projet devient le Projet Courant (avec une couleur de sélection). Les actions du menu Projet portent sur le projet courant.

Configuration d'un projet

  • Ouvrez le dialogue de Configuration Projet
    1. Sélectionnez le projet en cliquant (gauche) une de ses étapes
    2. Projet > Configurer
  • Changez le nom du projet
    • ⇒ Général > Renommer > Nom de projet
  • Changez l'option courante de mémorisation
    • ⇒ Quand le modèle associé calcule l'évolution de la scène et crée de nouvelles étapes, cette option détermine ce qui est gardé en mémoire. Elle peut être changée pour économiser de l'espace mémoire en cas de lancement de simulations longues avec de nombreuses données.
    • Mémorisation > Option courante > Etapes visibles
  • Consultez les paramètres du modèle associé au projet
    • Paramètres > Les noms en majuscules désignent les valeurs par défaut, les noms en minuscules désignent les valeurs courantes des paramètres.

Evolution

Déclenchez une phase d'évolution depuis une étape donnée.

  1. Ouvrez le Menu Etape (clic droit) sur l'étape de départ
  2. Evolution
  3. Choisissez une limite en fonction des caractéristiques du modèle (ex: un nombre d'années)
  4. Le modèle calcule différentes étapes et les lie derrière l'étape de départ
  5. Tous les visualiseurs synchronisés sur l'étape de départ montrent la dernière étape calculée (voir 8. Visualiseurs)

Intervention

Déclenchez une intervention sur une étape donnée

  1. Ouvrez le Menu Etape (clic droit) sur l'étape choisie
  2. Intervention
  3. Choisissez un outil d'intervention dans la liste
  4. Paramétrez et validez l'intervention
  5. Une nouvelle étape est ajoutée après l'étape désignée, portant le peuplement après intervention.

Visualiseurs

Les visualiseurs peuvent montrer une représentation du peuplement sous une étape de projet donnée. Cette représentation peut être graphique (carte, distribution) ou non (texte).

  • Ouvrez un visualiseur sur une étape donnée
    1. Cliquez l'étape que vous voulez visualiser (clic gauche)
    2. Choisissez l'onglet Visualiseurs dans le Sélecteur latéral
    3. Sélectionnez un visualiseur dans la liste (double-clic gauche)
    4. Le visualiseur s'ouvre, synchronisé sur l'étape donnée
    5. L'étape et le visualiseur sont marqués d'une même couleur
  • Synchronisez le visualiseur sur une autre étape
    1. Cliquez sur l'étape de départ (colorée)
    2. Double-cliquez sur l'étape d'arrivée
    3. La couleur se déplace vers la nouvelle étape
    4. Les visualiseurs qui étaient synchronisés sur l'étape de départ sont maintenant synchronisées sur l'étape d'arrivée
  • Chaque visualiseur fournit sa propre aide en ligne, accessible depuis son bouton ou son icone d'aide.

Sorties graphiques

Les sorties graphiques peuvent mixer des données extraites de plusieurs étapes d'un ou plusieurs projets. Ces représentations peuvent être graphiques (courbes, histogrammes, nuages de points…) ou non (tables, texte…).

  • Ouvrez une sortie graphique sur une étape donnée
    1. Cliquez l'étape considérée
    2. Choisissez l'onglet Sorties Graphiques dans le Sélecteur latéral (icone histogramme)
    3. Sélectionnez une sortie graphique dans la liste (double clic)
    4. La sortie graphique s'ouvre, synchronisée sur l'étape considérée
    5. L'étape et la représentation (ex: une courbe) partagent la même nouvelle couleur
  • Synchronisez la représentation (ex: courbe) avec une autre étape
    1. Cliquez sur l'étape de départ (colorée)
    2. Double-cliquez sur l'étape d'arrivée
    3. La couleur se déplace vers l'étape d'arrivée
    4. Les représentations (ex: courbes) qui étaient synchronisées avec l'étape de départ sont maintenant synchronisées avec l'étape d'arrivée
  • Ajoutez une représentation (ex: une nouvelle courbe) dans la sortie graphique
    1. Cliquez sur l'étape choisie (colorée ou non)
    2. Ctrl-cliquez dans la sortie graphique
    3. Une nouvelle représentation (ex: une nouvelle courbe) est ajoutée, avec une nouvelle couleur si nécessaire
  • Supprimez tous les outils (visualiseurs, sorties graphiques) sur une étape colorée
    1. Ctrl-cliquez sur l'étape colorée
    2. Tous les visualiseurs de même couleur sont fermés
    3. Toutes les représentations (ex: courbes) de même couleur sont retirées des sorties graphiques
    4. Les sorties graphiques vides sont fermées
    5. L'étape est maintenant sans couleur

Sauvegarde et ouverture des projets

Les projets peuvent être sauvegardés sur disque et rechargés ultérieurement exactement dans le même état. Le modèle associé est sauvegardé également avec son paramétrage courant pour pouvoir être réutilisé après réouverture.

Pour sauvegarder un projet sur disque

  1. Sélectionnez le projet en cliquant une de ses étapes
  2. Projet > Enregistrer Sous
  3. Choisissez une localisation et un nom de fichier (extension de fichier libre)
  4. Validez

Pour ouvrir un projet sauvegardé

  1. Projet > Ouvrir
  2. Sélectionnez le fichier contenant le projet dans le système de fichiers
  3. Un aperçu montre les propriétés du projet ou fichier sélectionné
  4. Validez

Sauvegarde et ouverture de la session

Une session est une collection de projets. Vous pouvez librement ouvrir plusieurs projets pour votre travail et les sauvegarder ensuite individuellement ou ensemble dans une session. Dans ce dernier cas, les projets sont toujours sauvegardés individuellement mais un fichier session est aussi sauvegardé. L'ouverture du fichier session réouvrira ultérieurement tous les projets.

Pour sauvegarder une session sur disque

  1. Fichier > Enregistrer Sous Session
  2. Choisissez une localisation et un nom de fichier (extension de fichier libre)
  3. Validez

Pour ouvrir une session sauvegardée

  1. Fichier > Ouvrir Session
  2. Sélectionnez le fichier contenant la session dans le système de fichiers
  3. Un aperçu montre les propriétés de la session ou du fichier sélectionné
  4. Validez

Groupes

Certains modèles gèrent des arbres individuels ou des cellules de terrain dans leurs structures de données. Pour ces modèles, il est possible de créer des groupes de tels arbres ou cellules de terrain. Ces groupes peuvent ensuite être utilisés dans les visualiseurs ou sorties graphiques (ex: restriction aux arbres supérieurs à 10m).

Ouvrez le Catalogue de Groupes

  1. Menu Etape > Grouper

Créez un nouveau groupe

  1. Catalogue de Groupes > Nouveau
  2. Choisissez un nom pour le groupe
  3. Choisissez un type de groupe (ex: Arbres / Dynamique)
  4. Sélectionnez un filtre
  5. Paramétrez le filtre
  6. Inspectez le résultat dans le témoin
  7. Optionnellement, raffinez la sélection avec d'autres filtres
  8. Quand tout est prêt, Validez
  9. Le groupe est sauvegardé sur disque, il est à présent connu de Capsis jusqu'à ce qu'il soit supprimé du catalogue

Personnalisez un groupe

  1. Catalogue de groupes
  2. Sélectionnez un groupe à personnaliser dans la liste
  3. Personnaliser
  4. Changer les paramètres des filtres
  5. Validez

Supprimez un groupe

  1. Catalogue de groupes
  2. Sélectionnez un groupe
  3. Supprimer

Impression

Apercevez le résultat de l'impression

  • Fichier > Aperçu avant impression

Imprimez les visualiseurs et sorties graphiques ouverts

  1. Fichier > Imprimer
  2. Choisissez l'imprimante et ses paramètres
  3. Validez

Aide en ligne

Une aide en ligne est disponible depuis l'interface graphique de Capsis.

Ouvrez l'aide en ligne

  • Aide > Rubriques d'aide
documentation/tutorial_fr.txt · Last modified: 2014/11/13 14:29 by coligny