AMAPstudio

User Tools


Tutorial : Starting with Capsis

Capsis launch

Change to the capsis_install_directory/capsis4/bin/ directory and run the capsis launcher script (launch in english with the -len option).

Windows
cd capsis_install_directory\capsis4
capsis

# Optional: start Capsis in english
capsis -l en
Linux / Mac OS X
cd capsis_install_directory/capsis4
sh capsis.sh

# Optional: start Capsis in english
sh capsis.sh -l en

You can check capsis option with the -h option

Available models

Capsis hosts models for forests / plantations growth and dynamics modeling.

To get the list of the installed models, use Help > About Capsis. The dialog shows the list of available models.

Project creation

All simulations are ran inside projects. Each project is linked to a specific capsis model, chosen at init time. Projects memorize the different steps of the simulation history. Each step has a date and holds a snapshot of the stand at this date, calculated by the linked model.

A project always contain a root step, supporting the initial stand of the simulation, either loaded from file or virtually generated.

  1. Project > New
  2. Choose a project name
  3. Select the model to be linked : Mountain
  4. Hit the Initialize button
  5. Specify the initial stand : Inventory > Virtual stand
  6. Check the other options : Plot > Cells > Cell width (m) : 10
  7. Validate

Project management

When the project is initialized (i.e. model parameters are set and initial stand is loaded), it appears in the Project Manager. A header shows its main properties (name, model name, surface…) and the initial stand is linked to the root Step with a date.

The Project Manager provides a Step contextual menu (the Step Menu) which contains Step management options.

When you click on a step (left button), it becomes the Current Step (with a pressed look) and the project becomes the Current Project (with a projet selection color). Actions in the Project menu occur on the current project.

Project configuration

  • Open the Project Configuration dialog
    1. Select the project by left-clicking one of its steps
    2. Project > Configure
  • Change the project name
    • General > Rename > Project name
  • Change the memory storage current status
    • ⇒ When the linked model calculates evolution and creates new steps, this option decides what is kept in memory. It can be changed to save memory space when running long simulations with a lot of data.
    • Memory storage > Current option > Visible Steps
  • Watch the settings of the capsis model linked to the project
    • Settings > watch the default values in uppercase and current values in lowercase

Evolution

Trigger an evolution phase from a given step

  1. Open the Step Menu on the starting step
  2. Evolution
  3. Fill in a limit depending on the model requirements (ex: a number of years)
  4. The model calculates different steps and links them after the starting step
  5. All Viewers synchronized with the starting step move to the last calculated step

Intervention

To trigger an intervention on a given step

  1. Open the Step Menu on the chosen step
  2. Intervention
  3. Choose an intervention tool in the list
  4. Parametrize and validate intervention
  5. A new step is added after the chosen step, carrying the stand after intervention

Viewers

Viewers can give a representation of the stand under a given project step. This representation can be graphical (maps, distribution) or not (text).

  • Open a Viewer on a given step
    1. Click the step you want to watch (left-click)
    2. Choose the viewer tab in the lateral Selector
    3. Select a viewer (double left-click)
    4. The Viewer opens, synchronized on the given step
    5. The step and the viewer are marked with a color
  • Synchronize the viewer with another step
    1. Click on the starting step (a colored one)
    2. Double-click on the step of arrival
    3. The color moves on the new step
    4. The Viewers which were synchronised with the starting step are now synchronized with the step of arrival
  • Each Viewer has its own online help, accessible from a help button or icon.

Graphical outputs

Graphical outputs can mix data extracted from several steps of one or several projects. These representations can be graphical (curves, histograms, scatterplots…) or not (tables, text…).

  • Open a Graphical output on a given step
    1. Click the considered step
    2. Choose the Graphical outputs tab in the lateral Selector (with an histogram icon)
    3. Select a Graphical output (double click)
    4. The Graphical output opens, synchronized with the considered step
    5. The step and the representation (ex: a curve) share the same new color
  • Synchronize a representation (ex: curve) with another step
    1. Click on the starting step (a colored one)
    2. Double-click on the target step
    3. The color moves to the new step
    4. The representations (ex: curves) which were synchronized with the starting step are now synchronized with the target step
  • Add a representation (ex: a new curve) in a Graphical output
    1. Click on the chosen step (colored or not)
    2. Ctrl-click in the Graphical output
    3. A new representation (ex: a new curve) is added, with a new color if needed
  • Remove all tools (Viewers, Graphical outputs) on a colored step
    1. Ctrl-click on the colored step
    2. All the Viewers with same color are closed
    3. All the representations (ex: curves) of same color are removed of the Graphical outputs
    4. The empty Graphical outputs are closed
    5. The step is now uncolored

Project saving and opening

Projects can be saved on disk and reloaded later in the same exact state. The linked model is also saved with its current settings in order to be reusable after re-opening.

  • To save a project on disk
    1. Select the project by clicking one of its steps
    2. Project > Save As
    3. Choose a location and file name (free file extension)
    4. Validate
  • To open a project from disk
    1. Project > Open
    2. Select the file containing the project in the file system
    3. An overview shows information of the selected project / file
    4. Validate

Session saving and opening

A Session is a collection of Projects. You can freely open several projects to work on, then save them individually or in a whole session. In this case, projects are still saved individually but a session file is also saved. Opening the session file will later re-open all the projects.

  • To save a session on disk
    1. File > Save As Session
    2. Choose a location and file name (free file extension)
    3. Validate
  • To open a session from disk
    1. File > Open Session
    2. Select the file containing the session in the file system
    3. An overview shows information of the selected session / file
    4. Validate

Groups

Some models manage individual trees or plot cells in their data structure. For these models, it is possible to create groups of such trees or plot cells. These groups can then be used in the Viewers (ex: restrict to trees higher than 10m) or graphical outputs.

  • Open the group catalog
    1. StepMenu > Group
  • Create a new Group
    1. Group catalog > New
    2. Choose a name for the group
    3. Choose group type (ex: Trees / Dynamic)
    4. Select a filter
    5. Parametrize it
    6. Inspect the result in the display
    7. Optionally refine selection with other filters
    8. When everything is ok, Validate
    9. The group is saved to disk, it is now known by capsis until it is removed from the catalog
  • Customize a Group
    1. Group catalog
    2. Select a group to be customized in the list
    3. Customize
    4. Change filters parameters
    5. Validate
  • Remove a group
    1. Group catalog
    2. Select a group
    3. Delete

Print

Preview the print result

  1. File > Print Preview

Print the currently opened Viewers and Graphical outputs

  1. File > Print
  2. Choose printer and settings
  3. Validate
documentation/tutorial_en.txt · Last modified: 2014/11/13 14:27 by coligny